CS crashes when opening my map (1.6)

Like such as the NIPPER
Post Reply
User avatar
func_?
Posts: 337
Joined: Wed Feb 21, 2007 4:19 am
Location: HK

CS crashes when opening my map (1.6)

Post by func_? » Fri Aug 20, 2010 12:10 am

My counter strike crashes when I open a "new game" for my custom map. However, the other default map works fine. Anyone know how to solve this problem?
Last edited by func_? on Fri Aug 20, 2010 12:20 am, edited 1 time in total.
-War does not determine who is right, war determine who is left.
User avatar
pepper
Posts: 2405
Joined: Mon Jan 04, 2010 6:26 pm
Location: s d

Re: CS crashes when opening my map

Post by pepper » Fri Aug 20, 2010 12:14 am

Counter Strike: Source?
Or Counter Strike?
How old is your computer?
Did you update your video drivers? Do you get any error messages at startup?
Also, it's highly likely that there is some bug in your map.
User avatar
func_?
Posts: 337
Joined: Wed Feb 21, 2007 4:19 am
Location: HK

Re: CS crashes when opening my map (1.6)

Post by func_? » Fri Aug 20, 2010 12:22 am

Cs 1.6 sorry forgot to add that detail.
My computer (laptop) was bought 2 years ago.
There are no error messages popping up when it crashes... actually the game freezes.
-War does not determine who is right, war determine who is left.
User avatar
Avvatar
Veni. Legi. Docuit, inportuna.
Posts: 10182
Joined: Fri Feb 21, 2003 3:58 am
Location: San Jose

Re: CS crashes when opening my map (1.6)

Post by Avvatar » Fri Aug 20, 2010 2:57 am

Post your compile log.
Image
User avatar
reaper4172
Posts: 279
Joined: Mon Aug 06, 2007 1:31 am
Location: Minnesota, US
Contact:

Re: CS crashes when opening my map (1.6)

Post by reaper4172 » Fri Aug 20, 2010 6:11 am

Be sure you don't have anything weird too. like somethings speed moving really fast, multi_manager triggering too many things, or trigger_hurt or env_explosion with the damage overly high.
<1.6 mapper>
reaper
User avatar
func_?
Posts: 337
Joined: Wed Feb 21, 2007 4:19 am
Location: HK

Re: CS crashes when opening my map (1.6)

Post by func_? » Sun Aug 22, 2010 11:43 pm

Ok, I just made another simple map and cs freezes as well, so I'm pretty sure it has nothing to do with my map. I'll post the compile log below but I just want to tell you guys that I normally use ZHLT to compile the maps.
** Executing...
** Command: Change Directory
** Parameters: "C:\Program Files\Steam\steamapps\spawnispro\counter-strike"


** Executing...
** Command: C:\PROGRA~1\VALVEH~1\tools\qcsg.exe
** Parameters: "c:\zhlt\awp_blocks_larger"

qcsg.exe v2.8 (Jan 31 2000)
---- qcsg ----
entering c:\zhlt\awp_blocks_larger.map

************ ERROR ************
Token too large on line 4


** Executing...
** Command: C:\PROGRA~1\VALVEH~1\tools\qbsp2.exe
** Parameters: "c:\zhlt\awp_blocks_larger"

qbsp2.exe v2.2 (Dec 28 1998)
---- qbsp2 ----

************ ERROR ************
Token too large on line 1


** Executing...
** Command: C:\PROGRA~1\VALVEH~1\tools\vis.exe
** Parameters: "c:\zhlt\awp_blocks_larger"

vis.exe v1.3 (Dec 30 1998)
---- vis ----
2 thread(s)
LoadPortals: couldn't read c:\zhlt\awp_blocks_larger.prt
No vising performed.

** Executing...
** Command: C:\PROGRA~1\VALVEH~1\tools\qrad.exe
** Parameters: "c:\zhlt\awp_blocks_larger"

qrad.exe v 1.5 (Apr 6 2000)
----- Radiosity ----
2 threads
[Reading texlights from 'C:\PROGRA~1\VALVEH~1\tools\lights.rad']
[1 texlights parsed from 'C:\PROGRA~1\VALVEH~1\tools\lights.rad']


************ ERROR ************
Token too large on line 1


** Executing...
** Command: Copy File
** Parameters: "c:\zhlt\awp_blocks_larger.bsp" "C:\Program Files\Steam\steamapps\spawnispro\counter-strike\cstrike\maps\awp_blocks_larger.bsp"


** Executing...
** Command: Copy File
** Parameters: "c:\zhlt\awp_blocks_larger.pts" "C:\Program Files\Steam\steamapps\spawnispro\counter-strike\cstrike\maps\awp_blocks_larger.pts"

The command failed. Windows reported the error:
"The system cannot find the file specified."

** Executing...
** Command: Copy File
** Parameters: +map "awp_blocks_larger" -game cstrike -dev -console +deathmatch 1
Mind you this map is the simple one, not the real one.
-War does not determine who is right, war determine who is left.
User avatar
koko
[citation needed]
Posts: 4159
Joined: Sat Apr 05, 2008 10:31 pm
Location: Hayden, ID
Contact:

Re: CS crashes when opening my map (1.6)

Post by koko » Sun Aug 22, 2010 11:49 pm

is your token too large?
lol this is a troll post ignore it but reading your error log that seems the to be the problem.


really your token is too large!!!
CaptainTripps wrote:I curse and complain all the time. The fuck you gonna do about it?
Image
User avatar
Avvatar
Veni. Legi. Docuit, inportuna.
Posts: 10182
Joined: Fri Feb 21, 2003 3:58 am
Location: San Jose

Re: CS crashes when opening my map (1.6)

Post by Avvatar » Mon Aug 23, 2010 9:20 pm

It seems obvious from your log that your map isn't even compiling. That is not what a compile log should look like. Google that token error.
Image
User avatar
func_?
Posts: 337
Joined: Wed Feb 21, 2007 4:19 am
Location: HK

Re: CS crashes when opening my map (1.6)

Post by func_? » Tue Aug 24, 2010 12:07 am

OK, I googled this up, and I opened the .MAP file to check for any extra long sentences... and I think I found it.
{
"classname" "worldspawn"
"classname" "worldspawn"
"MaxRange" "4096"
"mapversion" "220"
"wad" "\program files\valve hammer editor\wad\ajawad.wad;\program files\valve hammer editor\wad\cached.wad;\program files\valve hammer editor\wad\chateau.wad;\program files\valve hammer editor\wad\cs_747.wad;\program files\valve hammer editor\wad\cs_assault.wad;\program files\valve hammer editor\wad\cs_bdog.wad;\program files\valve hammer editor\wad\cs_cbble.wad;\program files\valve hammer editor\wad\cs_dust.wad;\program files\valve hammer editor\wad\cs_havana.wad;\program files\valve hammer editor\wad\cs_office.wad;\program files\valve hammer editor\wad\cstraining.wad;\program files\valve hammer editor\wad\cstrike.wad;\program files\valve hammer editor\wad\de_airstrip.wad;\program files\valve hammer editor\wad\de_aztec.wad;\program files\valve hammer editor\wad\de_piranesi.wad;\program files\valve hammer editor\wad\de_storm.wad;\program files\valve hammer editor\wad\de_vertigo.wad;\program files\valve hammer editor\wad\decals.wad;\program files\valve hammer editor\wad\halflife.wad;\program files\valve hammer editor\wad\itsitaly.wad;\program files\valve hammer editor\wad\n0th1ng.wad;\program files\valve hammer editor\wad\prodigy.wad;\program files\valve hammer editor\wad\tempdecal.wad;\program files\valve hammer editor\wad\torntextures.wad;\program files\valve hammer editor\wad\tswad.wad"
{
( -576 -640 512 ) ( -576 -64 512 ) ( 256 -64 512 ) 747BRW [ 1 0 0 0 ] [ 0 -1 0 0 ] 0 1 1
( -576 -64 480 ) ( -576 -64 512 ) ( -576 -640 512 ) 747BRW [ 0 1 0 0 ] [ 0 0 -1 0 ] 0 1 1
( 256 -640 480 ) ( 256 -640 512 ) ( 256 -64 512 ) 747BRW [ 0 1 0 0 ] [ 0 0 -1 0 ] 0 1 1
( 256 -64 480 ) ( 256 -64 512 ) ( -576 -64 512 ) 747BRW [ 1 0 0 0 ] [ 0 0 -1 0 ] 0 1 1 ...(deleted)
So is the problem here due to me uploading too many textures in Valve Hammer? If so, which ones would you recommend me to not use and stuff.
-War does not determine who is right, war determine who is left.
User avatar
Avvatar
Veni. Legi. Docuit, inportuna.
Posts: 10182
Joined: Fri Feb 21, 2003 3:58 am
Location: San Jose

Re: CS crashes when opening my map (1.6)

Post by Avvatar » Tue Aug 24, 2010 12:47 am

Well dear lord, lol. Remove whichever of those you're not actually using.
Image
User avatar
reaper4172
Posts: 279
Joined: Mon Aug 06, 2007 1:31 am
Location: Minnesota, US
Contact:

Re: CS crashes when opening my map (1.6)

Post by reaper4172 » Tue Aug 24, 2010 10:29 pm

Yeah, way too many WADs. If you feel you need certain textures from each of those, consider taking the textures you will use and make it into one wad. Chances are you are probably using only one or two off each WAD. I usually don't exceed 4 WADs when I am mapping.

See if that does anything by removing some, if not that eliminated one of the possibilities.
<1.6 mapper>
reaper
Post Reply